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Brief： 

This document lists some common problems and 

solutions for Telink Integrated Development 

Environment (IDE). 
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©  Telink Semiconductor 
All Right Reserved 
 

Legal Disclaimer 

Telink Semiconductor reserves the right to make changes without further notice to 

any products herein to improve reliability, function or design. Telink Semiconductor 

disclaims any and all liability for any errors, inaccuracies or incompleteness contained 

herein or in any other disclosure relating to any product. 

 

Telink Semiconductor does not assume any liability arising out of the application or 

use of any product or circuit described herein; neither does it convey any license 

under its patent rights, nor the rights of others 

 

The products shown herein are not designed for use in medical, life-saving, or 

life-sustaining applications. Customers using or selling Telink Semiconductor products 

not expressly indicated for use in such applications do so entirely at their own risk 

and agree to fully indemnify Telink Semiconductor for any damages arising or 

resulting from such use or sale.  

 

Information: 

For further information on the technology, product and business term, please 

contact Telink Semiconductor Company (www.telink-semi.com). 

For sales or technical support, please send email to the address of: 

telinkcnsales@telink-semi.com  

telinkcnsupport@telink-semi.com  

  

Te
li
nk
 f
or
 c
us
to
me
r

http://www.telink-semi.com/
mailto:telinkcnsales@telink-semi.com
mailto:telinkcnsupport@telink-semi.com


                                                     Telink IDE FAQs 

AN-16042800-E1           2 Ver 1.0.0 

 

Revision History 

Version Major Changes Date Author 

1.0.0 Initial release 2016/4 L.J.W., Cynthia 

Te
li
nk
 f
or
 c
us
to
me
r



                                                     Telink IDE FAQs 

AN-16042800-E1           3 Ver 1.0.0 

  

Table of contents 

1 Brief Introduction ................................................................................................... 5 

1.1 Host .................................................................................................................. 5 

2 Questions and Solutions ......................................................................................... 6 

2.1 When CJK name is used as folder or file, the compilation failed since file or 

path can’t be found. ................................................................................................... 6 

2.2 When the SDK is imported from a very long path, the compilation failed 

since file or path can’t be found. ............................................................................... 7 

2.3 When the SDK is imported, Eclipse sometimes crashed in Java with error 

such as “out of memory”. .......................................................................................... 8 

2.4 When I click on the Eclipse, it took long time to startup. ................................ 9 

2.5 How can I adjust the update site or frequency of checking update? ............ 10 

2.6 When I modify header file only, the project won’t be rebuilt? ..................... 12 

2.7 How can I Use Telink SDKs in IDE? ................................................................. 12 

2.8 How can I setup Java VM for Telink IDE? ....................................................... 14 

2.9 How can I exclude file or folder from build? ................................................. 16 

2.10 How can I search the SDK?............................................................................. 17 

2.11 How to disable the “Build Automatically” option? ........................................ 18 

2.12 Faster Eclipse Startup .................................................................................... 19 

2.13 Faster Make with parallel build ..................................................................... 20 

2.14 Prebuild steps with long path or cjk filename ............................................... 21 

2.15 Label decoration for exclude files .................................................................. 21 

 

  

Te
li
nk
 f
or
 c
us
to
me
r



                                                     Telink IDE FAQs 

AN-16042800-E1           4 Ver 1.0.0 

Table of figures 

Figure 1 Workspace encode ................................................................................ 6 

Figure 2 Include /Library path ............................................................................. 7 

Figure 3 Include /Library path ............................................................................. 8 

Figure 4 Startup settings ..................................................................................... 9 

Figure 5 Update settings.................................................................................... 10 

Figure 6 Import projects .................................................................................... 12 

Figure 7 Locate your projects ............................................................................ 13 

Figure 8 Java download ..................................................................................... 14 

Figure 9 Right click the file or folder ................................................................. 16 

Figure 10 Search dialog ....................................................................................... 17 

Figure 11 Build Automatically ............................................................................. 18 

Figure 12 Setup parralle build ............................................................................. 20 

Figure 13 general settings ................................................................................... 21 

 

  

Te
li
nk
 f
or
 c
us
to
me
r



                                                     Telink IDE FAQs 

AN-16042800-E1           5 Ver 1.0.0 

1 Brief Introduction 

This document mainly lists some FAQs and solutions for Telink IDE (Eclipse 4.x) 

on PC, Mac and Linux. Please check both version of OS and Eclipse to apply the 

solutions. 

 

1.1 Host 

 SDK from Telink 

 Telink IDE 
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2 Questions and Solutions 

In this section, interface of IDE version 1.5 is taken as an example. And the 

solutions can also apply to IDE version 1.3. 

 

2.1 When CJK name is used as folder or file, the compilation failed 

since file or path can’t be found. 

 

  Figure 1 Workspace encode 

Solution: 

Window -> Preferences -> General -> Workspace  

Tick “Other” and select “UTF-8” for the “Text file encoding” option . 
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2.2 When the SDK is imported from a very long path, the 

compilation failed since file or path can’t be found. 

 

  Figure 2 Include /Library path  

Solution:  

Project -> Properties -> C/C++ Build -> Settings -> Tool Settings -> TC32 Compiler -> 

Directories 

Select the configuration as needed in the “Configuration” combo box or by clicking 

“Manage Configurations”. 

Click the icon , add the location of “include” head file for compiler and library 

path for linker as needed.  
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2.3 When the SDK is imported, Eclipse sometimes crashed in Java 

with error such as “out of memory”. 

 

 Figure 3 Include /Library path  

Solution:  

Window -> Preferences -> C/C++ -> Editor -> Indexer 

User can disable the indexer (uncheck “Enable indexer” box) or adjust the options to 

minimize the issues of CDT.  
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2.4 When I click on the Eclipse, it took long time to startup. 

 

 Figure 4 Startup settings  

Solution:  

Window -> Preferences -> General -> Startup and Shutdown  

Double check the plug-ins not in use, and uncheck unnecessary ones. 
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2.5 How can I adjust the update site or frequency of checking 

update? 

 

Figure 5 Update settings 

Solution:  

Window -> Preferences -> Install/Update -> Available Software Sites  

Double check the update sites not in use. 
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Window -> Preferences -> Install/Update -> Automatic Updates 
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2.6 When I modify header file only, the project won’t be rebuilt? 

Solution:  

Just clean the project twice. Then rebuild all. 

  

2.7 How can I Use Telink SDKs in IDE? 

 

 

Figure 6 Import projects 

Solution:  

File -> Import (or right click on the “Project Explorer” window and select “Import”). 

-> General -> Double click “Existing Projects into Workspace”. 

Select the root directory to search for existing projects. 
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Tick the project(s) under the directory to be imported. 

Click “Finish”. 

 

 

Figure 7 Locate your projects 
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2.8 How can I setup Java VM for Telink IDE? 

Java installation package is available from the website 

http://www.oracle.com/technetwork/java/javase/downloads/index.html) 

 

  Figure 8 Java download 
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Solution:  

1. Download and install the JDK/JRE for your OS with 64 bits support.  

2. In short cut, append or modify arguments as 

“C:\TelinkSDKv1.5\msys32\eclipse.exe -vm [location where java vm 

installed]\jre\bin\server\jvm.dll” 

e.g. In eclipse.ini [Window/Linux], append or modify arguments as 

“TelinkSDKv1.5\msys32\eclipse.exe -vm [location where java vm installed]”. 

3. For Mac OS, if you're trying to get the VM that eclipse runs under, then it's the 

Info.plist you need to modify, and it should be changed in the section that says 

how to specify the different VMs. In my case, I changed it to run with the 1.6 VM 

using: 

<string>-vm</string><string>/System/Library/Java/JavaVirtualMachines/1.6

.0.jdk/Contents/Home/bin/java</string>  

in the eclipse array of the plist. 

If you want to force a specific 1.7 VM, you can use: 

<string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.7.0_2

5.jdk/Contents/Home/bin/java</string> 

 

Note: This is the Eclipse.app/Contents/Info.plist rather than eclipse.ini. This is 

because of the slightly different way that the Mac launches eclipse from other 

platforms. 
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2.9 How can I exclude file or folder from build? 

 

Figure 9 Right click the file or folder 

Solution:  

Right click on the “Project Explorer” window -> “Properties” -> C/C++ Build. 

Per the configuration, toggle the “Exclude resource from build” box. 
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2.10 How can I search the SDK? 

 

Figure 10 Search dialog 

 

Solution: 

1. On the main toolbar, click the “Search” icon . 

2. Enter file name in “Containing text” box. 

3. Press “Ctrl” and “H” keys at the same time (or click “Search” on the window) 

to start searching.  
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2.11 How to disable the “Build Automatically” option? 

By default, the Eclipse workbench is configured to build projects automatically. 

However, for C/C++ development you should disable this option, otherwise your 

entire project will be rebuilt whenever, for example, you save a change to your 

makefile or source files.  

Click Project -> Build Automatically and ensure there is no check mark beside 

the “Build Automatically” menu item. 

 

  Figure 11 Build Automatically 

 

  

Te
li
nk
 f
or
 c
us
to
me
r



                                                     Telink IDE FAQs 

AN-16042800-E1           19 Ver 1.0.0 

2.12 Faster Eclipse Startup 

Solution: 

Append these into Eclipse.ini after –vmargs. Some of them should be used carefully. 

-Xquickstart  

-Xverify:none 

-Xshareclasses:none  

-Xmn128m  

-Xss2m  

-Xms256m  

-Xmx512m  

-XX:PermSize=128m  

-XX:MaxPermSize=512m 

-XgcPrio:deterministic  

-XX:MaxGCPauseMillis=10 -XX:MaxHeapFreeRatio=70 

-XX:+UseG1GC -Xss2m -XX:+UseParallelGC -XX:+UseParNewGC 

-XX:+CMSConcurrentMTEnabled -XX:ConcGCThreads=2 -XX:ParallelGCThreads=2 

-XX:GCTimeRatio=49 -XX:GCPauseIntervalMillis=1000 

-XX:+UseCMSCompactAtFullCollection -XX:+CMSClassUnloadingEnabled 

-XX:+DoEscapeAnalysis -XX:+UseCompressedOops -XX:+AggressiveOpts 

-XX:+ExplicitGCInvokesConcurrentAndUnloadsClasses -XX:+UseFastAccessorMethods 
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2.13 Faster Make with parallel build 

 

  Figure 12 Setup parralle build 

Solution: 

Project -> Properties -> C/C++ Build -> Behavior -> Tick “Enable parallel build” and 

select number of jobs according to the CPU cores. 
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2.14 Prebuild steps with long path or cjk filename 

Solution: 

Append these into Eclipse.ini -Dfile.encoding=UTF-8 and use ‘’ or “” to quote it. 

 

2.15 Label decoration for exclude files 

 

Figure 13 general settings 

Solution: 

Window -> Preferences -> General -> Appearance -> Label Decorations 

Please check/uncheck label decoration items as needed, and click “Apply” to 

add/remove the gray out items. 

It won't affect the buildup but just highlight folder(s) not in use within IDE. 
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