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1 Brief Introduction

This document mainly lists some FAQs and solutions for Telink IDE (Eclipse 4.x)
on PC, Mac and Linux. Please check both version of OS and Eclipse to apply the

solutions.

1.1 Host

> SDK from Telink

> Telink IDE

AN-16042800-E1 5 Ver 1.0.0
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2 Questions and Solutions

In this section, interface of IDE version 1.5 is taken as an example. And the

solutions can also apply to IDE version 1.3.

2.1 When CJK name is used as folder or file, the compilation failed

since file or path can’t be found.

= Preferences [ [5] g

type filter text Workspace oo e
= See 'Startup and Shutdown' for workspace startup and shutdown preferences.
> Appearance
Compare/Patch
Content Types [¥] Build automatically
. Editars [] Refresh using native hooks or polling
Error Reporting Refresh on access
Globalization [7] Save automatically before build
Keys [] Always close unrelated projects without prompt

> MNetwork Connectic

Motifications ) o
A Workspace save interval (in minutes): 3
Perspectives

Search Workspace name (shown in window title):
> Security =
» Startup and Shutde Workspace path: EXwk\cjk

Tracing

UIR . [7] Show workspace path in window title
esponsiveness

VWeb Browser

Open referenced projects when a project is opened
. s ) Always () Never (@ Prompt
Changelog
» Help
. Install/Update Command for launching system explorer: explorer /E /select=%{selected_resource_loc}
. Library Hover
> Mylyn |_' Text file encoding MNew text file line delimiter
> Oomph | @ Default (M5950) @ Default Windows)
» Remote Development
. Remaote Systems © Other: | MSS50 @ Other: |Windows
> RPM l
v .P--mflr'r\rnl-.j X S [Restoregefaultsl l Apply ]

@ @ [ ok || cancel |

Figure1 =~ Workspace encode

Solution:
Window -> Preferences -> General -> Workspace

Tick “Other” and select “UTF-8" for the “Text file encoding” option .

AN-16042800-E1 6 Ver 1.0.0
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2.2

Click the icon

When the SDK is imported from a very long path, the

compilation failed since file or path can’t be found.

-
& Properties for 8263_BLE_Remote_UltraLlowCostSDK

[ERE==)

pe filter text

» Resource

Settings

- - -

4 C/C++ Build

Build Variables

Configuration iBZGS_remotepp [ Active ]

v] iManage Configurations...

Environment

P—

Logging
ool Chain Editor

» C/C++ General
Linux Tools Path
Project References
Run/Debug Settings

> Task Repaository

> Telink Tools
WikiText

P Tool Settings

| #: Build Steps |

Build Ar‘t\factl Binary Parsersl @ Error Parsers‘

[

[

[

1Y

1Y

& Additional Tools in Toalchain
8y TC32 CC/Assembler
2 General
(5 Paths
Debugging

553 TC32 Compiler
Directaries

Symbols

(2 Wamnings
(# Debugging
@ Optimization

% Language Standard
(2 Miscellaneous

83 TC32 C Linker
2 General
& Libraries
(2 Objects

83 TC32 Create Extended Listing
2 General

&3 TC32 Create Flash image
(2 General

83 Print Size
= General

Tl | »

Include Paths (-I)

Jprajfmeu
./projfcomman
fproj

aa8i @

@

’ Restore Defaults ] ’

Apply ]

[

ok || cansl |

Solution:

Directories

{I

AN-16042800-E1

“Manage Configurations”.

path for linker as needed.

Figure 2

Include /Library path

Project -> Properties -> C/C++ Build -> Settings -> Tool Settings -> TC32 Compiler ->

Select the configuration as needed in the “Configuration” combo box or by clicking

, add the location of “include” head file for compiler and library

Ver 1.0.0
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2.3

with error such as “out of memory”.

When the SDK is imported, Eclipse sometimes crashed in Java

-
& Preferences

type filter text
._Gepera
Appearance
» Autotools
> Build
Code Analysis
: Code Style

. Debug
il Types

Indexer
anguage Mappings
> Mew C/C4++ Project W

: Profiling
> Property Pages Setting

Task Tags

Template Default Val

Changelog

Help
Install/Update
Library Hower

Mylyn

Comph
» Remote Development
> Remote Systems

Indexer

[¥] Enable indexer
Indexer options
[¥]Index source files not included in the build
[#]Index unused headers
[TIndex all header variants

Index all variants of specific headers:

[[]Index source and header files opened in editor

[¥] Allow heuristic resolution of includes

Skip files larger than: 3 MB

Skip included files larger than: 16 ME

[7] Skip all references (Call Hierarchy and Search will not waork)

[7] Skip implicit references (e.g. overloaded operators)

[] skip type and macro references (Search for these references will not work)

Indexing strategy
[¥] Automatically update the index
Update index immediately after every file-save

Build configuration for the indexer
() Use active build configuration

@ Use the build configuration specified in the praject's indexer settings

> RPM
» Run/Debug Cache limits
- Team Index database cache:
> Telink Tools Limit relative to the maximum heap size: 10 %
- Tracing A
Absolute Limit: 64 MB
Header file cache (used by refactoring):
Absolute Limit: 64 MB
i = - - ’Restoregefaultsl ’ Apply ]
l:’?) @ [ oK l ’ Cancel ]
Figure 3 Include /Library path
Solution:

Window -> Preferences -> C/C++ -> Editor -> Indexer

User can disable the indexer (uncheck “Enable indexer” box) or adjust the options to

minimize the issues of CDT.

AN-16042800-E1 8
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2.4 When I click on the Eclipse, it took long time to startup.
f & Preferences l =l ér

type filter text Startup and Shutdown Crr

G |
[7] Refresh workspace on startup
4 Appearance

[¥] Confirm exit when closing last window

Colors and Fonts
Label Decorations

Compare/Patch Blug-ins activated on startup:

Content Types Equinax Provisioning Platform Automatic Update Suppart
> Editors RSE UL

Error Reporting

Ul Responsivensss Manitoring
Codan Analysis Ul for C/C++
Eclipse Automated Error Reporting

Globalization
Keys

» Metwork Connections

Notifications Marketplace Client

Perspectives Devhelp Libhaver plugin

FEEEEEEEEEE

Search Mylyn Tasks UI
i ylyn Team UL
I‘ Startup and Shutdowr I Oomph Setup UL
Workspaces Oomph Dynamic Waorking Sets Editor
Tracing

UI Responsiveness Mc
\Web Browser
» Workspace
C/C++
Changelog

7

7

Help
Install/Update
Library Haver

7

7

Mylyn

7

7

Comph
Remaote Development

7

7

Remote Systems
RPM
Run/Debug
Team

Telink Tools

Tracing

7

7

v

v

7

g P— . ’ Restore Qefaults] ’ Apply ]

@ Ce) [ oK ] ’ Cancel ]

Figure 4 Startup settings

Solution:
Window -> Preferences -> General -> Startup and Shutdown

Double check the plug-ins not in use, and uncheck unnecessary ones.

AN-16042800-E1 9 Ver 1.0.0
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2.5 How can | adjust the update site or frequency of checking

update?
2 Preferences Llﬂ‘ﬂ_hr

type filter text Install/Update Cr=-y
4 General i Browsing for updates
- Appearance

@ Show only the |atest versions of available software
Compare/Patch -
(71 Show all versions of available software

Content Types
> Editors When software selected for an install wizard may not be compatible
Error Reporting

() Open the wizard anyway to review or change selections

Globalization - -

(©) Report the problems and do not open the wizard
Keys

» Network Connectic

Notifications Uninstall or update software that is already installed

@ Ask me what to do when it happens

Perspectives
Search
> Security
. Startup and Shutdc
Tracing
UI Responsiveness
Web Browser =
4 Workspace
Build Order
Linked Resourc
Local History
> C/C++
Changelog
> Help
4 | Install/Update

Automatic Update:

Available Software
> Library Hover

Mylyn

> Oomph
Remote Development

> Remote Systems
> RPM

: Run/Debug

> Team

- — : [Restoregefau\ts” Apply ]

@ @j [ oK ] [ Cancel I

Figure 5  Update settings

Solution:
Window -> Preferences -> Install/Update -> Available Software Sites

Double check the update sites not in use.

AN-16042800-E1 10 Ver 1.0.0
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Available Software Sites oo A
type filter text
Name ‘ Location |~ Add..
QﬂEclox http://download.gna.org/eclofupdate —
¥ Eclox http://download.gna.org/ecloxfupdate |z B
Qﬂﬂle:jhomefdata,-’users,-’vkongfd... http://download.eclipse.org/tools/fcdt/re Remove
W] Helios http://download.eclipse.org/releases/he ||
QﬂHex Editor http:/fehep.sourceforge.netfupdate Reload

W telink ide update

| The Eclipse Praject Updates
QuUpdate Site

] vim

W] WindowBuilder

| WindowBuilder

W] WindowBuilder

http:/ fwoww.telink-us.com:B821/updatesit
http://download.eclipse.org/eclipsefupd
http://community.polarion.com/projects;
http:/ fvimplugin.sf.net/update

http://dl.google.com/eclipsefinst/d2wbp
http://download.eclipse.orgfwindowbuild
http://eclipse.org/downloads/sums.php?

= 0:] http:/fcommunity. polarion.com/projects;
K| http://dev.eclipse.org/svnroot/dsdpforg
= 0:] http://dev.eclipse.orgfviewcvsfindex.cgi/
K| http://download.eclipse.org/birt/update-
= 0:] http://download.eclipse.org/datatools/u
| http://download.eclipse.org/dsdp/mtjfu; ~

4| 1

| 3

Automatic Updates

Window -> Preferences -> Install/Update -> Automatic Updates

[¥] Automatically find new updates and notify me

Update schedule

Every day

@ Look for updates each time Eclipse is started

() Look for updates on the following schedule:

1:00 AM

Download options

@ Search for updates and notify me when they are available

Enable

() Download new updates automatically and notify me when ready to install them

When updates are found

@ Notify me once about updates

(") Remind me about updates every:

30 minutes

AN-16042800-E1 11 Ver 1.0.0
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2.6  When | modify header file only, the project won’t be rebuilt?

Solution:

Just clean the project twice. Then rebuild all.

2.7 How can | Use Telink SDKs in IDE?

& Import [ (=] ﬂ

Select
Create new projects from an archive file or directony. | E a4 ﬁ I

Select an import source:

type filter text

.3

= General
5 Archive File

[=> Existing Projects into Workspace I
[} File System

[T Preferences

= CfC++

= Git

= Install

= Oomph

» (= Remote Systems

= RPM

= Run/Debug

= Tasks

.« (=5 Team

m

Figure 6 Import projects

Solution:
File -> Import (or right click on the “Project Explorer” window and select “Import”).
-> General -> Double click “Existing Projects into Workspace”.

Select the root directory to search for existing projects.

AN-16042800-E1 12 Ver 1.0.0
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Tick the project(s) under the directory to be imported.
Click “Finish”.

-
& Import

Import Projects
Select a directory to search for existing Eclipse projects.

o

@ Select root directory:  El\code\BTEERIZ\B263_SDK_Release, - [ Browse...

(71 Select archive file:

Browse._.

Projects:

B263_BLE_Remote SDK V1.2 (E\code\FTBER F\B263_SDK_| Select All

Deselect All

Refresh

fi

1| 1

Options

[[] Search for nested projects

[[] Copy projects into workspace

[ Hide projects that already exist in the workspace

Warking sets
[V] Add project to working sets
Waorking sets: |

® Mext = [ Einish

|| cancel

Figure 7 Locate your projects

AN-16042800-E1 13
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2.8 How can | setup Java VM for Telink IDE?

Java installation package is available from the website

http://www.oracle.com/technetwork/java/javase/downloads/index.html)

Overview Downloads Documentation Community Technologies Training

Java SE Downloads

=2 Java 22 NetBeans
pownLoAD = |

Java Platform (JDK) 8uGs / Bugs MetBeans with JDK 8

| Java Platform, Standard Edition |

Java SE Bu65 [ Bues

Java SE BuB5 includes important security fixes. Oracle strongly recommends that all Java SE 8
users upgrade to this release. Java SE Bugt is a patch-set update, including all of 8u65 plus
additional features (described in the release notes).

Learn more #

= Installation Instructions
DOWNLOAD #

[
IU
=

= Release Motes
= Oracle License
= Java SE Products Server JRE
= Third Party Licenses
= Cerified System Configurations

= Readme Files
= JDK ReadMe

[
A
m

DOWNLOAD *
» JRE ReadMe

Which Java package do | need?

= Software Developers: JDK (Java SE Development Kit). For Java Developers. Includes a
complete JRE plus tools for developing, debugging, and monitoring Java applications.

= Administrators running applications on a server: Server JRE (Server Java Runtime
Environment) For deploying Java applications on servers. Includes tools for JWVi
monitoring and tools commonly required for server applications, but does notinclude
browser integration (the Java plug-in}, auto-update, nor an installer. Learn more »

= End user running Java on a desktop: JRE: (Java Runtime Environment). Covers most
end-users needs. Contains everything required to run Java applications on your system.

Java SE 7 and Java SE 6 updates

Updates for Java SE 7 released after April 2015, and updates for Java SE 6 released after April
2013 are only available to Oracle Customers through My Cracle Support (requires support
login).

Figure 8  Java download

AN-16042800-E1 14 Ver 1.0.0
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Solution:

1. Download and install the JDK/JRE for your OS with 64 bits support.

2. In short cut, append or modify arguments as
“C:\TelinkSDKv1.5\msys32\eclipse.exe -vm  [location where java vm
installed]\jre\bin\server\jvm.dll”

e.g. In eclipse.ini [Window/Linux], append or modify arguments as
“TelinkSDKv1.5\msys32\eclipse.exe -vm [location where java vm installed]”.

3. For Mac OS, if you're trying to get the VM that eclipse runs under, then it's the
Info.plist you need to modify, and it should be changed in the section that says
how to specify the different VMs. In my case, | changed it to run with the 1.6 VM

using:

<string>-vm</string><string>/System/Library/Java/JavaVirtualMachines/1.6
.0.jdk/Contents/Home/bin/java</string>

in the eclipse array of the plist.
If you want to force a specific 1.7 VM, you can use:
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/jdk1.7.0_2

5.jdk/Contents/Home/bin/java</string>

Note: This is the Eclipse.app/Contents/Info.plist rather than eclipse.ini. Thisis
because of the slightly different way that the Mac launches eclipse from other

platforms.

AN-16042800-E1 15 Ver 1.0.0
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2.9 How can | exclude file or folder from build?
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£ Properties for version_h [ E éj
| C/C++ Build T
Resource
» C/C++ Build
» C/C++ General Configuration: ’8263_remotepp [ Active ] v] ’Manage Configurations...
Run/Debug Settings
"] Exclude resource from build
« Refresh Policy
The following resources will be refreshed after the project is built (external builder [ 444 Rasource_.
Resources
" Add Exception...
I (= B263_BLE_Remate_SDK_V1.2 :
N Edit Exception..
Delete...
’Restore Qefaults] ’ Apply ]
® [ OK l [ Cancel ]

Figure 9 Right click the file or folder

Solution:
Right click on the “Project Explorer” window -> “Properties” -> C/C++ Build.

Per the configuration, toggle the “Exclude resource from build” box.

AN-16042800-E1 16 Ver 1.0.0
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2.10 How can | search the SDK?
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-
& Search | 5]

| B Remote Search | = File Search |17 Task Search | &7 C/C++ Search | &7 Git Search|

|Containing text:

- [ Case sensitive

[ Regular expression

[['wWhale word

* = any string, ? = any character, , = escape for literals: * 7

File name patterns (separated by comma):

* - Choose...

* = any string, 7 = any character, lx = excluding =)

[[1 Consider derived resources

Scope

i@ Workspace Selected resources Enclosing projects

® Replace.. ][ Search ]

Cancel ]

Figure 10 Search dialog

Solution:

1. On the main toolbar, click the “Search” icon = * ~
2. Enter file name in “Containing text” box.

3. Press “Ctrl” and “H” keys at the same time (or click “Search” on the window)

to start searching.

AN-16042800-E1 17 Ver 1.0.0
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2.11 How to disable the “Build Automatically” option?

By default, the Eclipse workbench is configured to build projects automatically.

However, for C/C++ development you should disable this option, otherwise your

entire project will be rebuilt whenever, for example, you save a change to your

makefile or source files.

Click Project -> Build Automatically and ensure there is no check mark beside

the “Build Automatically” menu item.

& c/C++ - Eclipse SDK

AN-16042800-E1

File Edit Refactor MNavigate Search Run Q=8 Window Help
1
. - B [ . _
- @ - © Close Project IQ
X S
= = Ctrl+B D
% S et L—[\:‘ Fre - Build parallel (s
s | 1] ._1§"" = Build Configurations 3
ERES HelloWorld ~ . ; :
<) Binaries B'l-” Working Set
(2 Includes Cn... -
= ﬁ hello.exe - [x&86/le] v Build Automatically
[A] basic_string.h Make Target R
[ char_traits.h - & .
[€] main.cpp Properties
El iostream

Figure 11 Build Automatically
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2.12 Faster Eclipse Startup

Solution:

Append these into Eclipse.ini after —-vmargs. Some of them should be used carefully.

-Xquickstart

-Xverify:none

-Xshareclasses:none

-Xmn128m

-Xss2m

-Xms256m

-Xmx512m

-XX:PermSize=128m

-XX:MaxPermSize=512m

-XgcPrio:deterministic

-XX:MaxGCPauseMillis=10 -XX:MaxHeapFreeRatio=70

-XX:+UseG1GC -Xss2m -XX:+UseParallelGC -XX:+UseParNewGC
-XX:+CMSConcurrentMTEnabled -XX:ConcGCThreads=2 -XX:ParallelGCThreads=2
-XX:GCTimeRatio=49 -XX:GCPauselntervalMillis=1000
-XX:+UseCMSCompactAtFullCollection -XX:+CMSClassUnloadingEnabled
-XX:+DoEscapeAnalysis -XX:+UseCompressedOops -XX:+AggressiveOpts
-XX:+ExplicitGCInvokesConcurrentAndUnloadsClasses -XX:+UseFastAccessorMethods

AN-16042800-E1 19 Ver 1.0.0
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2.13 Faster Make with parallel build

= Properties for ble_sdk 1t o]

[fme fiter tet C/C++ Build & - -

Configuration: |8266_ble_master_kma_dongle [ Active ] x| Manage Configumﬁons...l

[E] Builder Se & Refresh Policy |
" Tool Chain Editr o
[ CAZ+4+ Crenersl - Budd setting:
. Limx Tools Path ¥ Stop on fiest budd ervor v Enable paralle]l build
.. Project R_eferepces + sz optimal jobs (4)
Ezf:go;mg é‘hﬁpry " Tse parallel jobs: m
- pumDebug Settings £ Use wnlimited jobs
- Task Repository
- Tolnk Took  Workbench Build Behavior
Workbench build type: Iake build target:
[~ Build on resource save (duto build) [a1 Variahles. . |
Note: See Workbench automeatic build preference
¥ Enild Tncrememntal build) Jall Variables... |
¥ Clean Jclean Variables... |

Restore Defanlts | Apply |

@) OE | Concel |

Figure 12  Setup parralle build

Solution:

Project -> Properties -> C/C++ Build -> Behavior -> Tick “Enable parallel build” and

select number of jobs according to the CPU cores.

AN-16042800-E1 20 Ver 1.0.0
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2.14 Prebuild steps with long path or cjk filename

Solution:

Append these into Eclipse.ini -Dfile.encoding=UTF-8 and use “ or

2.15 Label decoration for exclude files

= Preferences

[type filter text

E..

Label Decorations

on

to quote it.

=101

- - -

Label decorations show extrs infornmnation about an itern on itz label or deon,
Belect which addibonal decorations should be displased .

LLahe 4 Avwailable label decorations:
- Compare/Patch . lma.ry Emcuﬁam 'ecnmt:ur
g;.‘;f“t Types C/C++ Files and Folders Hue
R CIC++ Files and. Falders with Customized Build Settings
- Brror Reporting )
. CHlobalization O CAC++ Indexed Files
- Kevs CIC++ Missing Include Folders
- Wetwork Connections O Contadners with Resounce Filters
- Notifications File Icons Based On Content Analysis
- Perspectives it
gemhty Jawva Executable Decorator
- Securi .
- Atartup and Shotdowen L?hra.r_\)r Decarstor
. Tracing Link Decorator
. I Responsvensss Mondto le-“l*ﬁd Resources
- User Storage Service Linked Trace
- Web Browser Seript Executable Decorator
(- Workspace Subdysten Ervor Decorator
it Symbolic links
[]ﬁ I eslog Task Change Set Decorator
- Help
- Tnstall T pdate Tazk Context Decorator
- Library Hower Task Decorator
- Mylm Trace Experiment Folder
[+ Domph Trace Folder
[+ Remote Development Wirtnal Folders
[+ Remote Systems Tirtyal Object Decorator
&-RPM
- RuDebug
[+ Team L
- Telink Taols Description:
- Tracing IDecnmtes somrce files and folders excloded from CAC+H budld.
Restore Defaults Apply
? 0K |  Camel |
Figure 13  general settings
Solution:

Window -> Preferences -> General -> Appearance -> Label Decorations

Please check/uncheck label decoration items as needed, and click “Apply” to

add/remove the gray out items.

It won't affect the buildup but just highlight folder(s) not in use within IDE.

AN-16042800-E1
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